guiderdoni.net

Bloc notes : spip, css, xhtml, web, standards, mac ...

Accueil > Spip > Problème d’activation des plugins

Articles de cette rubrique

Articles

publie le lundi 2 octobre 2006 par Alexandra

Problème d’activation des plugins

Si vous avez du mal à activer les plugins suite à une mise à jour, voici les différentes étapes qu’il vous faudra suivre.

1. Désactiver tous les plugins

2. Vider son cache

3. Vérifier que ecrire et ecrire/data soient en chmod 777

4. Dans ecrire, data enlever

- charger_plugins_options.php
- verifier_presence_plugins.php
- charger_pipelines.php
- charger plugins_fonctions.php

5. Prendre les dernières versions des plugins
http://zone.spip.org/files/spip-zone/

6. Puis réactiver les plugins.
Ca aura pour effet de recréer les quatres fichiers enlevés.

Et maintenant, tout devrait marcher !

Pour Spip 1.9.2 et SVN

Attention, les 4 fichiers .php ne sont plus dans ecrire/data mais dans tmp.

Forum

Répondre à cet article

4 commentaires

Problème d’activation des plugins en 1.9.2

Bonjour et merci pour cet article qui m’a dépanné plus d’une fois. Pour Spip 1.9.2 je suis la même procédure avec ces modifications à l’étape 4 :

Dans le dossier temp enlever
charger_pipelines.php
charger_plugins_fonctions.php
charger_plugins_options.php
plugin_xml.cache
verifier_plugins.txt

ps : la barre de raccourcis typo des forums de ce site génère des erreurs javascript lors du survol des 3 derniers boutons (voir le lien attaché pour corriger le problème)

> Spip 1.9.2 et la barre de raccourcis typos : http://weblog.eliaz.fr/article43.htm (...)

27 mars 2007, par bb - repondre message

Problème d’activation des plugins

Bonjour,

confronté au même problème en 1.9.2b, c’est la seule page que j’ai trouvé qui traite du problème.

Pour moi j’ai toujours le problème après. Ce que je ne comprend pas, c’est que j’ai installé un autre spip dans le même dossier et dans la même version, puis j’ai copié le dossier plugin du 1er dans le second. Les dossiers /tmp des deux côtés sont identiques au niveau droits :

drwxr-xrwx
drwxr-xrwx

donc "tout le monde" a tout les droits sur le dossier (pas besoin de mettre 777), eh bien dans la nouvelle version je peux activer/désactiver les plugins dans n’importe quel sens et n’importe quelle combinaison fonctionne sans aucun problème. Dans le 1er, certaines combinaisons désactivent tout.

Donc à priori même avec les droits correctement paramétrés, il peut y avoir autre chose qui bloque. Je me demande quel type de contrôle supplémentaire peut faire SPIP. Le log d’Apache ne mentionne rien, le log de SPIP précise :

donc rien de particulier et je ne vois plus dans quelle direction chercher.

Thierry B.

30 juillet 2007, par Thierry Bothorel - repondre message

Bonjour Thierry,

avez-vous trouvé une solution ? Je suis confronté au même problème, j’ai vu que vous aviez posté sur le forum SPIP (sans réponse...) merci si vous pouvez m’aider !

Yves

2 novembre 2007, par Yves - repondre message

Problème résolu, c’était un problème de configuration de la base de donnée. Les explications sont sur ce forum :

http://www.spip-contrib.net/SPIP-1-9-Les-Plugins#forum399801

Bon courage !

3 novembre 2007, par Yves - repondre message
2005-2017 - Contenu en GPL http://www.guiderdoni.net - Site réalisé avec SPIP 
rechercher - plan du site - prive - alexandra.guiderdoni@gmail.com
CSS - XHTML - squelette